DHCP: Настройка опции 43

Страница перенесена в Confluence

 

Точки доступа под управлением Wimark FW принимают адрес платформы / контроллера по опции 43. Формат для DHCP сервера isc-dhcp-server ниже, для остальных настраивается аналогично

...
     ddns-update-style interim;
     allow bootp;
     option space WIMARK_AP;
     option WIMARK_AP.server-address code 241 = array of ip-address;
     subnet 192.168.247.0 netmask 255.255.255.0 {
     authoritative;
     option routers 192.168.247.1;
     option subnet-mask 255.255.255.0;
     option domain-name "cisco.com";
     option domain-name-servers 192.168.247.2, 192.168.247.3;
     range dynamic-bootp 192.168.247.11 192.168.247.254;
     default-lease-time 300;
... 

class "Wimark_AP" {

       match if option vendor-class-identifier = "wimark";
       option vendor-class-identifier "wimark";
       vendor-option-space WIMARK_AP;
       option WIMARK_AP.server-address 192.168.247.5; }
}

Пример конфигурации для KEA DHCP

{
"Dhcp4": {
    "authoritative": true,

    "option-def": [
        {
            "name": "server-address",
            "code": 241,
            "space": "wimark",
            "array": true,
            "type": "ipv4-address"
        }
    ],

    "client-classes": [
        {
            "name": "VENDOR_CLASS_wimark",
            "option-def": [
                {
                    "name": "vendor-encapsulated-options",
                    "code": 43,
                    "encapsulate": "wimark",
                    "type": "empty"
                }
            ],

            "option-data": [
                {
                    "name": "vendor-encapsulated-options",
                },
                {
                    "name": "server-address",
                    "space": "wimark",
                    "data": "192.168.247.5",
                    "always-send": true
                },
            ]
        },
    ],
}

Теперь адрес платформы предполагается по IP адресу 192.168.247.5

Для микротик:

1. Convert your public IP to hex. The option 43 value has to be in HEX to work.

192=C0

168=A8

200=C8

10=0A

2. Your option 43 value will be "0x0104" + the HEX of the IP.

So in my example it is: "0x0104C0A8C80A"

3. Open up a new terminal on your Mikrotik or ssh in and type:

/ip dhcp-server option add code=43 name=unifi value=0x0104C0A8C80A

/ip dhcp-server network set 0 dhcp-option=unifi



Revision #4
Created 6 October 2022 15:15:13 by p.ivantsov
Updated 29 June 2023 14:25:23 by Ольга Шаповалова